脆弱性対応ウォッチ重大・クリティカル脆弱性のクラウド別対応まとめ
最新更新履歴CriticalHigh回避策のみパッチありAWSGCPAzureLinux
Critical CVSS 9.8 NEW
CVE-2026-110186

IBM Langflow OSS のコード生成の制御不備で未認証RCE(CVSS 9.8・1.13.0 で修正)

情報取得日: 2026/10/29・本ページは公開情報の非公式まとめです

CVE IDCVE-2026-110186
製品IBM / Langflow OSS 1.0.0〜1.12.8
CVSS9.8(Critical)
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
種別 (CWE)CWE-94 コードインジェクション
登録/公開日2026/10/29
出典https://nvd.nist.gov/vuln/detail/CVE-2026-110186

概要

**Langflow OSS の 1.0.0〜1.12.8 に、未認証のリモート攻撃者が任意のコードを実行できる脆弱性がある。** 原因はコード生成の制御の不備(CWE-94)。IBM のセキュリティ速報(2026年10月28日公開・29日更新)で公表され、CVSS は IBM の CVSS 3.1 で **9.8 Critical**(認証不要)。NVD は Undergoing Analysis。 **同じ速報の他の CVE。** 認証の不備でセキュリティ制限を回避される CVE-2026-93680(9.8)、低権限ユーザーが Agentic Assistant 経由で OS コマンドを実行できる CVE-2026-110193(8.8)、資格情報の保護不足 CVE-2026-110192(6.5)、依存ライブラリ Hono の3件が含まれ、いずれも 1.13.0 で修正された。 **悪用状況。** 2026-10-30 時点で CISA KEV には未収載。ただし Langflow は過去に複数の脆弱性が KEV に収載されており、公開環境は狙われやすい。

クラウド/OS 別の対応状況

各ベンダー公式アドバイザリで確認できた事実に基づき整理しています。確認できていない項目は「情報確認中」と明記し、存在しないパッチ番号・バージョンは記載しません。

AWS / GCP / Azure / Linux いずれも対応区分は同じです: パッチあり(アプリ更新) 参照先も共通です(一次情報)。 下の表は環境ごとの補足です。
環境対応状況対応方法・備考
AWS (ECS/EC2) パッチあり(アプリ更新)
EC2 / ECS / EKS 上で動かしている Langflow を 1.13.0 以上へ更新する(コンテナはイメージを差し替えて再デプロイ)。
AWS 側の修正ではなくアプリケーションの更新が対処。IBM は回避策を示していない。
参照リンク
GCP パッチあり(アプリ更新)
Compute Engine / GKE / Cloud Run 上の Langflow を 1.13.0 以上へ更新する。
GCP 側にパッチは無い。
参照リンク
Azure パッチあり(アプリ更新)
Azure VM / AKS / Container Apps 上の Langflow を 1.13.0 以上へ更新する。
Azure 側の修正ではなくアプリケーションの更新が対処。
参照リンク
Linux パッチあり(アプリ更新)
pip / uv で導入した Langflow を 1.13.0 以上へ更新する。
ディストリの標準パッケージではないため USN / RHSA には出ない。
参照リンク

解決の方向性(パッチ/回避策/代替)

**Langflow OSS を 1.13.0 以降へ上げる。** IBM は回避策を示していない。pip なら pip install --upgrade "langflow==1.13.0"、コンテナなら langflowai/langflow:1.13.0 を使う。 更新前にデータベース・シークレットキー・アップロード済みファイルをバックアップする。自動ログイン(auto login)を使っている環境は、更新後にパスワードでのサインインが必要になるので IBM の手順に従って準備する。過去の修正版(1.12.3 など)で止めている環境も本件の影響範囲に入るため、1.13.0 まで上げる。

よくある質問(CVE-2026-110186)

CVE-2026-110186(Langflow OSS 1.0.0〜1.12.8)の影響は?

Critical(CVSS 9.8)に分類されるIBM Langflow OSS 1.0.0〜1.12.8の脆弱性です。**Langflow OSS の 1.0.0〜1.12.8 に、未認証のリモート攻撃者が任意のコードを実行できる脆弱性がある。** 原因はコード生成の制御の不備(CWE-94)。IBM のセキュリティ速報(2026年10月28日公開・29日更新)で公表され、CVSS は IBM の CVSS 3.1 で **9.8 Critical**(認証不要)。NVD は Undergoing Analysis。 **同じ速報の他の CVE。** 認証の不備でセキュリティ制限を回避される CVE-2026-93680(9.8)、低権限ユーザーが Agentic Assistant 経由で OS コマンドを実行できる CVE-2026-110193(8.8)、資格情報の保護不足 CVE-2026-110192(6.5)、依存ライブラリ Hono の3件が含まれ、いずれも 1.13.0 で修正された。 **悪用状況。** 2026-10-30 時点で CISA KEV には未収載。ただし Langflow は過去に複数の脆弱性が KEV に収載されており、公開環境は狙われやすい。

CVE-2026-110186 の対応方法・回避策は?

**Langflow OSS を 1.13.0 以降へ上げる。** IBM は回避策を示していない。pip なら pip install --upgrade "langflow==1.13.0"、コンテナなら langflowai/langflow:1.13.0 を使う。 更新前にデータベース・シークレットキー・アップロード済みファイルをバックアップする。自動ログイン(auto login)を使っている環境は、更新後にパスワードでのサインインが必要になるので IBM の手順に従って準備する。過去の修正版(1.12.3 など)で止めている環境も本件の影響範囲に入るため、1.13.0 まで上げる。

自分の環境が CVE-2026-110186 の影響を受けるか確認するには?

IBM Langflow OSS 1.0.0〜1.12.8 を利用している場合、稼働バージョンが影響範囲に含まれるかを一次情報(https://nvd.nist.gov/vuln/detail/CVE-2026-110186)で確認してください。AWS・GCP・Azure・Linux それぞれの対応状況は本ページの「クラウド/OS 別の対応状況」表にまとめています。確認できていない項目は「情報確認中」と明記しており、存在しないパッチ番号・バージョンは記載していません。

参考情報(出典)

本ページの記載は下記の一次情報に基づく非公式まとめです。数値・対応状況は各出典元で最終確認してください。

ベンダー公式・PSIRT アドバイザリ
NVD(CVE 基本情報・CVSS スコアの出典)
免責: 本ページは CISA KEV・NVD・各ベンダー公式アドバイザリ等の公開情報をもとにした非公式まとめです。修正バージョンや対応可否は変更される場合があります。実際の対応は必ず 出典元および各ベンダー公式情報・自環境で確認してください。

« 一覧に戻る